Issue(s)

[Lestrades.com] Nao 尚

  • I'm Share-Locked
  • Administrator
  • Posts: 1,373
  • Trades: 219
Re: Issue(s)
« Reply #255,  »
I apologize for the downtime today. It was due to a faulty SQL query I wrote to execute something else faster, but that ended up being so slow it killed the server. Oops!

/u/humpaaa

  • Full Member
  • ▶ ¦ Yep
  • Posts: 190
  • Trades: 10

[Lestrades.com] Nao 尚

  • I'm Share-Locked
  • Administrator
  • Posts: 1,373
  • Trades: 219
Re: Issue(s)
« Reply #257,  »
I know, I know, devotee is the one in charge of the server, but he's often AWOL...
He assured me a while ago that he had an auto-renewal script enabled for the site, but it's obviously not working, so we're probably condemned to have this issue every few months.
Unless someone wants to volunteer their server for future hosting, I can't fix that on my side, I'm afraid.
I did tell him on Steam chat, but I don't want to bother him too much.
Re: Issue(s)
« Reply #258,  »
I've sent Devotee an e-mail, which he's more likely to notice than his Steam messages.
Hopefully, it'll be fixed quickly...

Super annoying. :-/
Re: Issue(s)
« Reply #259,  »
So, still no answer from Devotee... It's like he doesn't care, or isn't online anymore.

My PC died on me last week, and I'm still in the process of restoring everything on the new one. It's taking time. I haven't got access to the FTP yet. But it made me think, I really should move the website to another server. Especially since the online services are starting to die out mostly because of the SSL failure -- for instance, SteamTrades ratings are no longer updated. Also, it looks like there are missing bundles in the bundle page. The latest Humble Choice isn't showing up, despite trying to update it manually. I don't know if it's related to SSL or maybe they changed their code, but right now I can't test, because I don't have my usual tools installed.

So, in the meantime, has anyone got some space somewhere..? Lestrade's isn't that big of a website, it doesn't take gigabytes of data, it just needs a robust MySQL setup and at most a Gb of folder space (possibly less.)
Unfortunately, on my other host, I don't have the space for that.

I don't want to let LT's die. There are still hundreds of users who would like to keep it online. I'm sure one of you guys is in IT and has a server available..?
Even a slower one is fine. LT's code is optimized enough that it doesn't need a fast CPU.

Pika! Pika!

  • Jr. Member
  • Posts: 52
  • Trades: 68
Re: Issue(s)
« Reply #260,  »
Hopefully Devotee can still be reached or someone else has a server available. Alternatively maybe there is enough demand for it to have numerous members chip in a small amount for online hosting.

devotee

  • Newbie
  • Posts: 28
  • Trades: 14
Re: Issue(s)
« Reply #261,  »
Just a quick update.

The auto-renewal script is working but Let’s Encrypt migrated from ACME v1 to v2 and dropped all support to v1. Unfortunately I can't upgrade certbot on the server to use the new ACME v2 protocol.

I'm going to try to use another client to renew the certificate but the best approach would be to update the whole server to the latest Debian release (11). I was waiting for a new release before upgrading. However that's another issue because reinstalling the server means quite a lot of work to do (and probably some downtime).


[Lestrades.com] Nao 尚

  • I'm Share-Locked
  • Administrator
  • Posts: 1,373
  • Trades: 219
Re: Issue(s)
« Reply #264,  »
@devotee
Quote from devotee on October 8th, 03:50 PM
The auto-renewal script is working but Let’s Encrypt migrated from ACME v1 to v2 and dropped all support to v1. Unfortunately I can't upgrade certbot on the server to use the new ACME v2 protocol.
Unfortunately, SSL communication between servers still isn't established. I looked at my code and it just says error 0 when I try to get a file through curl.
When I use file_get_contents over SSL, it gives me this:

error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

Apparently meaning there's a problem with the cacert.pem file location or related configuration.
This has been going on since October 7, one day before your message, so I'm guessing it's related to your intervention.

Because of that, bundles have yet to be updated. Nothing since September 30. Quite annoying.
Do you have somewhere I can contact you in priority? Last time I tried e-mail and Steam, and no replies for weeks... :-/
WhatsApp, Discord, anything? Something modern? You know I'm only going to write to mention these issues... And it also helps with your own websites...