Milouze

  • Newbie
  • Posts: 14
  • Trades: 10
Re: Issue(s)
« Reply #150,  »
That was my first try. Tried again now on my iPhone 7 (so Safari it is), still the same.
It's frustrating: I can list the matches, open a new tab to create the offer, preview it and then nothing else.

[Lestrades.com] Nao 尚

  • I'm Share-Locked
  • Administrator
  • Posts: 1,175
  • Trades: 186
Re: Issue(s)
« Reply #151,  »
Anyone else?

Can't debug without an iPhone...
Re: Issue(s)
« Reply #152,  »Last edited
Apologies for the website being down about half an hour.
I executed a long query by mistake in my admin panel, and for some reason I didn't have a slot left to launch a process to kill all other processes. I ended up writing the script in PHP and brute-forcing the kill.
(Heck, I even changed the database password, hoping it'd force the kill... Nope, it didn't.)

PS : Milouze, ça va mieux ton problème d'iPhone, "vieux" ?
Re: Issue(s)
« Reply #153,  »
Known issue, talking to myself:

- Create an offer, send it.
- Click Edit offer.
- Reload page.
- Submit.
- A new offer is created, older offer remains in Editing mode.

This is due to the recent AJAX implementation... I'm not keeping the offer ID around at that point. Shouldn't be too hard to fix but I can't be arsed for now.

dys

  • Newbie
  • Posts: 1
  • Trades: 0
Re: Issue(s)
« Reply #154,  »
In Matches view, my custom properties are teal (color: #3eb2cb;), and the other trader's custom properties are yellow (color: #ffc833;).
Except for the other trader's Estimated Trading Value, which is also being shown in teal (color: #3eb2cb;).

[Lestrades.com] Nao 尚

  • I'm Share-Locked
  • Administrator
  • Posts: 1,175
  • Trades: 186
Re: Issue(s)
« Reply #155,  »
Should be fixed now. I never noticed the bug because it was untestable for me-- the only users to use custom values so far have been me and Zomby (with whom I also have only Subnautica in common... Gosh I nearly gave away that game to a scuba-diving friend for fun, didn't realize it'd be the only way for me to 'reach' other traders lol. Maybe I should add imaginary popular games to my tradables now.)
Guys, start tagging tradables & wishlists! I find it much simpler to tag a game "$4" than manually adding some kind of "CS:GO key x2" tag or custom note... As for wishlisted entries, I tend to tag shit games with a custom value of $0.05 or less, to indicate that I'm not willing to trade more for it than another worthless game.
Re: Issue(s)
« Reply #156,  »
Okay, I also fixed the issue with submitting offers above... That was more complex than I thought. Required a few changes here and there. Hopefully that doesn't create NEW problems, lol.
Also a limitation: I'm not storing quantities, so if you just reload the page, quantities will be reset to the actual amount of items in your offer, i.e. "5 out of 5" instead of "4 out of 5". I can fix that too, but I'm in less of a hurry. I hate touching up on my offer code... It's just so complicated with the AJAX implementation. (But it's so cool, too.)

eagletorch

  • Newbie
  • Posts: 5
  • Trades: 3
Re: Issue(s)
« Reply #157,  »
I can't edit or make new offers on mobile on either safari or chrome on iOS. I like hat he layout was responsive, maybe a lot more QA testing needs to be done on mobile devices

[Lestrades.com] Nao 尚

  • I'm Share-Locked
  • Administrator
  • Posts: 1,175
  • Trades: 186
Re: Issue(s)
« Reply #158,  »
I do at least half of my offers with Chrome for Android, I don't remember any recent changes that might hurt.

Your description isn't enough. Can't edit? What does it mean, there's no Edit button? Or the button doesn't do anything? Or it loads a new page, but not the Edit page?

eagletorch

  • Newbie
  • Posts: 5
  • Trades: 3
Re: Issue(s)
« Reply #159,  »
The page loads, but clicking the Edit button doesn't do anything.
Re: Issue(s)
« Reply #160,  »
Still can't send any offers on Chrome on iOS

[Lestrades.com] Nao 尚

  • I'm Share-Locked
  • Administrator
  • Posts: 1,175
  • Trades: 186
Re: Issue(s)
« Reply #161,  »
Oh yes, forgot about that sorry...
Mostly because I was unable to figure out your issue.

I've removed a small bit of code that disables the button after a press. Please tell me if that fixes it... (It's only removed if you're on iOS, BTW. If it still doesn't work, I'll disable it for everyone for testing purposes.)
Re: Issue(s)
« Reply #163,  »
Sorry, I'm not even sure what your problem is, and why it's happening at all..? (I mean, "Remove from library" shouldn't even show up during a BVG sync? Only when syncing with Steam..?)
My syncing code, AFAIK, is solid enough to accomodate for all situations.
Although, to be clear, removing library items probably won't work because Steam will re-add them later if it's in your Steam library according to their API data. You can only remove a library item manually if it's a DLC or package *or* it was revoked and marked as such. If it's not seen as revoked, then it means you still have those, no..?

nhex

  • Newbie
  • Posts: 15
  • Trades: 5
Re: Issue(s)
« Reply #164,  »
I can't send any trade offers - I click "send offer" which is green, and something happens, but the offer doesn't get made.