A1ice[useless]

  • Newbie
  • Posts: 3
  • Trades: 16

Lestrade 尚

  • Byte me.
  • Administrator
  • Posts: 816
  • Trades: 92
Re: Issue(s)
« Reply #136,  »
Sorry I've been offline most of the day. I'll look into it within an hour.
I also noticed offer creation was slightly broken, in that maybe it's not possible right now. Possibly due to a commit I shouldn't have made, mixing up the old preview and new preview systems. Ouch. That hurts. Sorry about that.
I think I'll just go full on new system tonight, and I'll fix the remaining issues later.
Re: Issue(s)
« Reply #137,  »
I've uploaded the admin version of my trick, it's working well for me, hopefully for you too.
Enjoy the increased speed :)

A1ice[useless]

  • Newbie
  • Posts: 3
  • Trades: 16
Re: Issue(s)
« Reply #138,  »
Problem: if you create offer - it will be 1:1, so your need edit it after creating

Lestrade 尚

  • Byte me.
  • Administrator
  • Posts: 816
  • Trades: 92
Re: Issue(s)
« Reply #139,  »
Ah, that's exactly the kind of thing I feared could happen... hmm. I'll look into it. (Note, though, that I'm aware some people prefer having a 1:1 by default but I don't.)

One of the other things is that if you reload the page while creating the offer, it won't remember the quantities either. I'd need to save that as well.
Re: Issue(s)
« Reply #140,  »
OK, got what you mean. Whatever you choose, it's always a 1:1 at submit time.
Unable to find reason for now. Will keep looking.

Flying Potato

  • Newbie
  • Posts: 3
  • Trades: 0
Re: Issue(s)
« Reply #141,  »
Hi, I got a problem : when I click on "Send offer", nothing happens. Tried on several browsers and still the same issue :/

Lestrade 尚

  • Byte me.
  • Administrator
  • Posts: 816
  • Trades: 92
Re: Issue(s)
« Reply #142,  »
Working for me. Anyone else?

Also, apologies for the site giving an error message for over an hour... I was right in the middle of fixing a bug on the homepage and hit a colon instead of a semicolon on my keyboard, uploaded the file and then realized I had to hurry to get my kid from school. Happens sometimes. Really sorry, I feel bad when these things happen, but I didn't even get a Steam chat message about it, otherwise I'd have gotten a notification and would have fixed this half an hour ago when I went back home.

Drebian

  • Newbie
  • Stubbornly Optimistic Hufflepuff
  • Posts: 14
  • Trades: 7

Lestrade 尚

  • Byte me.
  • Administrator
  • Posts: 816
  • Trades: 92
Re: Issue(s)
« Reply #144,  »
Yeah so it's probably a problem not related to my code. Would need a step by step guide then...

Flying Potato

  • Newbie
  • Posts: 3
  • Trades: 0
Re: Issue(s)
« Reply #145,  »
There we go !
I go on the "Matches" tab, then click on Send Offer.
I select the game I want to trade, and the game I want to have, then "Preview Offer".

The trade detail boxes appear, and when I click on "Send offer", they disappear for a very short while and then reappear, but nothing happens.

If you need any more info, I'll try to be as precise as possible.

Lestrade 尚

  • Byte me.
  • Administrator
  • Posts: 816
  • Trades: 92
Re: Issue(s)
« Reply #146,  »
Yes, because it's obviously not happening for anyone else.
When was your last successful 'Send offer' that you can remember?
Oh wait, I just checked, you're a newbie, you haven't sent anything yet.
The 'they disappear for a short while' thing is normal. It's a visual clue that the page is being reloaded with Ajax (so that it doesn't have to reload the list of games from both users at the very top of the page.) It normally ONLY happens when clicking 'Preview offer'. Clicking on 'Send offer' should NOT show a fade-out effect, instead it'll take you to the finalized offer page, with the 'Edit' and 'Cancel' buttons. (Hmm, maybe I should add a visual clue that the offer was successfully sent, BTW...)
So, it's important that you confirm you're seeing the fade-out effect even on the 'Send offer' button, actually.

I develop the site under Opera, which uses Chromium (Chrome) as its engine. That should handle a good 60% of users. The site is also confirmed to work fine in Firefox. IE, normally should work on recent versions... Can't make promises for IE 6-7. Then again, they have like a 0.1% market share altogether...

Flying Potato

  • Newbie
  • Posts: 3
  • Trades: 0
Re: Issue(s)
« Reply #147,  »Last edited
The fade-out effect appears when clicking on '"Send Offer" unfortunately.
Well, I'm on Firefox 55.0.3 running on Mac OS, not sure if this can help. Also tried with Safari with no luck.
I'm downloading Opera right now, going to test that first thing tomorrow and will report here !

Edit : Well, couldn't wait, and everything works smoothly on Opera. :)

Lestrade 尚

  • Byte me.
  • Administrator
  • Posts: 816
  • Trades: 92
Re: Issue(s)
« Reply #148,  »
Plus, good opportunity to try out Opera :P (I'd recommend installing Sidewise as well. It's a good vertical tab list with plenty of features for power users.)

Maybe it's a bug I recently introduced in Firefox, then... Can anyone else try it out? It's not currently running on my PC and I'm busy on other things and I have too many tabs in Firefox and it'll take a while to load and... Ah well, anyway!